Noob AMB82-Mini (RTL8735B) Upload Fail

I am probably missing something simple, but I cannot upload the Arduino blink skech to an amb82-mini. I am using a clean, updated install of Ubuntu on a Celeron platform. The board appears to connect at ttyS4, with settings Erase then Upload, Auto Flash Enabled, Standard Lib Disabled, Upload Speed 2000000. The sketch will compile, but then it fails to connect, error messages including:
Ping fail
NOR flashloader loading fail
Uart boot fail
Upload fail
.ping fail

Nothing appears on the serial monitor.

Please help this lost noob…
Thanks!

Hi @BadBetta

Welcome to AmebaIoT Forum! :grinning:

Please refer to our AmebaIoT Forum FAQ for help:

For more details, you can also read the Getting Start manual on our official website.

Alternatively, you also can join our community Facebook ZH/EN for help.

Thanks and happy coding!

Hello!

Thank you for your response.

I still cannot enter download mode with the AMB82-Mini. I am doing the following:

  1. Plug Board in using microusb (right side connection near red led)
    - All leds (RG&B) flash quickly and then stay lit
  2. Open Arduino Blink sketch & Arduino Serial Monitor (blank)
  3. Press and hold Uart Download button (left side button near blue led)
  4. Press and release Reset Button (right side button near red led)
    - The green led turns off, the red and blue leds stay on
  5. Release Uart Download button
    - Nothing shows on the Serial Monitor
    - Upload fails
  • Pressing Reset again causes the blue & green leds to flash quickly (red stays on) and then all leds stay on

Please help. I have tried 3 different boards and many operating systems (Ubuntu, Debian, Kali, Raspbian, Windows 10 & 11) without success. I would like to be able to use this board in my current project, but it seems I may need to use something else (esp32?) since I cannot get this to work.

Also, I do not have access to social media in my current work environment, so I appreciate your help using the forum.

Thank you,
JR

Hi @BadBetta,

Thanks for providing more details regarding your questions.

After step 2 , you can follow the video instruction here to enter Download Mode on AMB82.

After entering the UART Download mode, you should be able to see the log in your serial monitor indicating your board is able to receive an uploaded image:

image

Alternatively, you can try with another USB cable to prevent connectivity issues.

If you are still not able to enter the download mode after trying the above methods, please provide the log message after step 1 here for issue assessment.

Thanks!

Hi


, friends, I hope you can help me, I also have this problem, I bought 02 AMB82 board, and I have the same problem, I cannot load any code and carry out the uart steps, it also recognizes the CH340 cable and the port, when it comes to perform the download also follow the steps of the buttons and I get this image I hope you can help me, thank you very much

Hi @luiscat95,

you may refer to this reply, Noob AMB82-Mini (RTL8735B) Upload Fail - #4 by dakamaster. Thank you :slight_smile:

1 Like

Hi. I had the same problem as in above post with upload fail…ping retry fail…with new board today and blink test sketch. I made many tries on the recommended use of the boot and reset button sequence with no success. Finally I just held down the boot button while it uploaded, …dot sequence. I did nothing with the reset button and it booted up…upload success. Maybe change instructions if this is universal?

Hi @Mel,

There is no change in instructions. Can you double check one thing, when you go into serial monitor, press the two buttons at the side of AMB82-mini, screenshot what you see there.

Thank you.

Hi. Here is what I see after upload, then when press both at same time, Blink sketch stops:

After I changed blink time and did the one boot button hold upload again, then pressed both:

Is it a board/bootloader defect then or?
Cheers
Mel

Hi Again. After a few more upload attempts after making sketch changes, the single button method no longer worked either; I just get variations of this ping fail, as others have:

Serial monitor shows things like this, in this case when I get same fail, when trying to upload object detection example:

Currently no way I see to upload?
Cheers
Mel

Hi @Mel,

For the first picture, this shows that you are not in upload mode (which is pressing the two buttons) when you click on the compile button.

For the second picture, please change the serial monitor baud rate from 9600 to 115200 at the middle right side of the second picture.

Rule of thumb is

  1. Go to serial monitor, set to 115200 baud rate. Press the two buttons at the side of AMB82-Mini.
  2. You should see this picture.

This is a sign that you are in upload mode and you can compile and upload your code.

Thanks.

To everyone experiencing the communication issue above - after hours of fighting with the board, I’ve come to the following result: First, the sequence to enter upload mode is pressing Reset (the button next to the red LED), then press Download, then release Reset, and then release Download. Second, the cable is very important; after replacing several cables, I found one that establishes good communication and manages to upload the program without errors. I don’t know why this is, but I had a similar issue with ESP32, probably due to the driver; maybe Realtek should provide a verified cable with the kit. Good luck to all enthusiasts!