Win11 Cant recognize AMB82

I ordered 2 AMB82 boards and when i plugged the board via mini USB i got all the lights but nothing happened inside the Arduino APP no ports were visible, and nothing in the device manager,
i tried to install the driver as recommended by the official website
"If you have a driver issue with connecting the board to the computer please go to CH341SER.ZIP - NanjingQinhengMicroelectronics for the USB driver.
" but still nothing happened, what can be the reason my computer does not recognize that board?
Thanks

Edit:
I do not have a memory chip yet, did you guys plug your AMB82 mini without a memory chip and it works

Hi @GalGol,

Are you connecting to the right port, you should be connecting the mini USB on the bottom right side of the board. What Arduino IDE version are you using? Ameba ARDUINO: Getting Started with AMB82 MINI (RTL8735B) – Realtek IoT/Wi-Fi MCU Solutions

P.S You do not need to put in the SD card in order for the PC with Win11 to detect AMB82.

Thank you.

Hey, Thanks for your replying,

Regarding the port i am using the CH34C
i Inserted a SD card but still nothing is happening

Regarding the IDE Version

‫בתאריך יום ב׳, 29 בינו׳ 2024 ב-3:25 מאת ‪Kelvin Huang via Realtek Ameba IOT Developers Forum (AMB82 RTL8722 RTL8195 RTL8710 RTL8720 BW16 Development board) - IOT / MCU Solutions 瑞昱開發者論壇 開發板 开發者论坛 开發板‬‏ <‪notifications@ameba.discoursemail.com‬‏>:‬

Hi @GalGol,

I have a PC with Windows11 set up. I have directly connected AMB82 Mini to PC and it can detect with no issue.

I am suspecting that there are some issues with your PC environment. Can you try this guide How to Install CH340 Driver in Windows [4 Steps with Pictures] ?

Thanks!

hey

When doing uninstall i get this the AMB is plugged in


i tried to manually install the driver

but nothing is happening
i was trying to do the same process with both of them amb82
note:
i am not able to make it works in win 10 other laptop ch34
How can i successfully uninstall it not from the installer but manually maybe i will uninstall and install

‫בתאריך יום ב׳, 29 בינו׳ 2024 ב-10:06 מאת ‪Kelvin Huang via Realtek Ameba IOT Developers Forum (AMB82 RTL8722 RTL8195 RTL8710 RTL8720 BW16 Development board) - IOT / MCU Solutions 瑞昱開發者論壇 開發板 开發者论坛 开發板‬‏ <‪notifications@ameba.discoursemail.com‬‏>:‬

Hi @GalGol ,

This is very strange…
Please check if your PC is able to detect any ports. If you have any other USB to TTL adapter, please try to plug in and see from your device manager if you are able to see any ports. Let’s try to debug if this is a hardware issue for the boards or is it a PC environment issue.


Thanks!