AmebaD evaluation board do not recognized by J-Flash

Hi all
I am using the AmebaD (RTL8722DM processor) on a BW16 module, which I used it to evaluate my code as a development board. I have success to upload and download my compiled code with no problem through SWD connection and J_Link emulation.
Lately, I received the real development board (RTL-AMEBAD-MB-4V0), which is working fine with its internal code loaded by the factory on WiFi communication only.
I want to download my code to it, but first to upload the code from it in order to deserve it for future use.
I connected the J-Link emulation to it (SWD) and operate the GDB server (as described in AN0400 doc), and it works fine.
When I tried to connect via J-Flash - it only recognized the M-23, and fails, even the project definitions are with no mistakes (please refer to the screenshots attached).
Why? Is there any way to fix it? and, what is the CFI file that is missing?
Thank you in advance


InkedScreenshot J-flash|624x500

1 Like

Hi Evyatar_Nassie,

Firstly, can you provide information on which SDK version you are using?

I do not have experience with using J-Flash, but I have used the image flashing script in the SDK through the “make flash” command, and that has worked fine for me, is there a reason for using J-Flash instead of the included script?
From my testing, it seems the script is able to flash even while only connected to the M23 core.

Alternatively, you could also try uploading the binaries using the ImageTool, which can be found in chapter 8 of the AN0400 document.

Thank you very much for the prompt reply
Regarding your questions:

  • I’m using the latest SDK (I’m not sure what its version, but it compiled last month), sent last week.
  • I’m using the J-Link because I’m using the IAR IDE, which use it automatically. Beside it I was used the GCC “make all” and make flash, but it very slowly, and the debugger is limited (comparing to IAR).
  • I will try today your tool in order to have the binary code programmed in the internal flash, as explained earlier.
    Thank you very much!
1 Like

Hi Evyatar,

Just FYI,
The SDK version is the 2 digits number(sometimes with alphabet suffix) in the SDK’s root directory name.

For Ameba D, it is usually v6.2 or something similar

Dear all!

  1. the Imagetool you recommend is to download my code to the flash. I need the opposite - to read the flash to my PC. Please recommend on a way to do it
  2. The SDK name is: “RTL8270D_SDK.tar.gz”… except the mismatch name of it (it should be written as RTL8720D…) - there is no way to know the version as Xidameng wrote…

thanks!

I thought you need to download the code to board.

BTW, there are some variations to the Ameba D SDK, especially yours is for RTL8720DN.

A suggestion here is to download the open source SDK from official Github @ GitHub - ambiot/ambd_sdk: SDK for AmebaD
And re-attemp

I was gladly doing that, but the SDK is missing bluetooth examples and IAR configuration…
I am now try to operate the simple_config example (BT to config the WiFi on my device… I am in a status that the BT printout that advertising starts, but it not visible on any BT search tool (nRF_Config for example). I keep looking and analyzing the code to see what is going wrong there,
Thank you!

Hi Evyatar,

Have you tried Realtek’s custom APP for this feature?

It’s called Easy WiFi Config on Playstore, I just tested it, it is working.

Since there is no information about the version of the SDK you have, it’s hard to troubleshoot, but 1 thing I can assure you is that the feature you mentioned works with the latest SDK, so you might need to contact your supplier/FAE for more information.

Alternatively, this feature has been ported to Arduino platform, if you just wanna see how it should function and its log, feel free to try out this example ,
Ameba Arduino: [RTL8722CSM] [RTL8722DM] BLE – WiFi Configuration Service – Realtek IoT/Wi-Fi MCU Solutions