Basic application build

Hi All,

I need to build and start basic application on RTL8720DM chip but not demo board.
I built basic project from sdk and tried to upload via JLink 9.
During building on Ubuntu 20 using command “make all” I faced with problem what some .sh and .py are not executable and fixed it. But other problem still exists:

make[2]: Leaving directory ‘/home//ambd_sdk/project/realtek_amebaD_va0_example/GCC-RELEASE/project_hp/asdk/make’
Traceback (most recent call last):
File “/home//ambd_sdk/project/realtek_amebaD_va0_example/GCC-RELEASE/project_hp/asdk/”, line 515, in
File “/home//ambd_sdk/project/realtek_amebaD_va0_example/GCC-RELEASE/project_hp/asdk/”, line 19, in obj_list_gen
num = len(item)
TypeError: object of type ‘filter’ has no len()
========= linker img2_ns start =========

This bug occurs many times. Is it critical?

Then I run “make setup GDB_SERVER=jlink” and it is good.

Finally I rum “make flash” and it doesn’t work at all.
Load flash loader.
/home//ambd_sdk/project/realtek_amebaD_va0_example/GCC-RELEASE/project_lp/asdk/gnu_utility/gnu_script/rtl_gdb_flash_write.txt:27: Error in sourced command file:
gnu_utility/gnu_script/target_FPGA.axf: No such file or directory.

My investigations show that *.axf were not copied during the build.

Q: how start and debug the basic application on this chip against the manual?


thanks for raising this issue. The cause has been found, you can refer to this commit for the missing files.

1 Like