Help needed to erase the default firmware on a standalone BW16

So now that I’ve successfuly erased the default firmware on a module (green PCB). I want to do the same with a standalone BW16.
I’ve wired similarly to this setup : (because I followed this tutorial


I’m able to get the B&T logo. But I don’t kown how to get access to the special shell where I can type AT Commands.

I’ve tried to use image tool to erase the firmware but it didn’t work.

Any ideas?

The B&T logo should only appear on serial_Tx and serial_Rx, while the image upload and image erase function operates over log_Tx and log_Rx, so those two pins should be connected. Then enter image upload mode by connecting log_Tx to GND and resetting.

Yes those two pins and only those two pins are connected (of course VCC and GND are also connected)
I did the procedure multiple times
but all I got is this:

it stopped when I sent things.
To be clear this is a pic of my setup:

Also this could help, it seem like the B&T message is accompanied by others information that I didn’t have on the first one

The question marks should be normal. The chip sends NAK over UART when it is waiting in download mode, which shows up as unprintable characters.
the additional information with the B&T logo shows that the B&T image hardfaults after booting. I suspect that this may be due to an incomplete flash erase, do you know if this appeared the first time, before you tried erasing it?
Another possibility is that your USB-UART adapter is unable to supply sufficient current on the 3.3V line, you might want to try a standalone power supply, or grab the 3.3V from other development boards.
Also, how does the flash erase procedure fail? are there any error messages?

1 Like

I don’t remember if I was seeing this error message when I first plugged the device.
In others case this is the screenshot of the image tool doing flash erase (I tried many Baud rates)

I use the FT232 UART to USB adapter
I tried to connect the 3.3V line of the BW16 to the 3.3V line of the not standalone development board along with ground
I also tried to connect the same 3.3V to a external power supply along with ground
But it failed
(note: when in use with the external PS the BW16 sometimes keep resetings and sometimes send B&T logo with no error message )
I don’t known if my UART adapter is designed to be powered with the 5V of its USB and at the same time have the 3.3V line plugged via an external PS.
It may well be because of the 3.3V supply. I will try to do different setup.
Do you have advice for the wiring?

sometimes, when it’s not printing failure with B&T logo it’s send : AT_UART_CONF: 38400,8,1,0,0

your wiring should look similar to this:

please try this out and let me know the results.

Ok, thanks with this wiring it’s working great, now I don’t have any error dump on A&T logo; I will try to flash

It’s not working I don’t have access to the AT command prompt

what’s the meaning of " AT_UART_CONF: 38400,8,1,0,0" apart from the obvious serial baud rate what’s the meaning of the others numbers.

ok so I’m now to the point where Image Tool is not outputing any errors it’s just flashing very quickly just say:
COM3 is open successfully!
Flash erase is processing…
COM3 is closed successfully!
no error of “clear flash status register fail”

So I guess it’s a step in the right direction
but it’s still not working because the B&T logo it still there.

a few questions:
Is the B&T firmware still hardfaulting after boot?
What chip is on the USB-UART adapter, and what baudrate are you using in the image tool?
Perhaps you can try erasing 4MB of flash?

No the B&T isn’t hardfaulting after boot thanks to proper wiring with the power supply
I’m using the FT 232 USB-UART adapter
I’m using 115200 as a baudrate in the image tool like instructed by this tutorial

I am not sure why the flash erase still seems to be failing, you might want to try out the other methods and see if those work.

Since I don’t have access the the AT command prompt I don’t see how the first method will work.

I think the key is to access the AT cmd prompt. So could I access it ?

the AT cmd prompt should be avaliable at the same UART port as the B&T logo and messages?
might as well try both UART ports

Well, when I’m just connected to the Serial via PB1 and PB2 I’m getting the AT command prompt so definitively not the same as the B&T logo

1 Like

Ok so I finally managed to flash a standalone BW16.
And without even using windows.
I got access to the AT command interface via Serial PB1 & PB2 baudrate 38400
I used the Over the Air method : connected to my WiFi and on my linux issued the command :
cat OTA.bin | nc -lvnp 8002
to spawn a TCP server to send the firmware.
It worked perfectly.

Thanks for your help :slight_smile:

good to hear that it finally worked for you.