Compilation Error on AMB82-mini Using CUSTOMIZED_YOLOV7TINY - 'signal: segmentation fault'

I want to use a customized Yolov7tiny-Pytorch on AMB82-mini. I tried to modify the “ObjectDetectionLoop” example code by replacing




And follow the official document, save a new project at
put the yolov7_tiny.nb that converted on AMB82 AI Model Conversion website in that folder.

When I verify the code, there is an error 'Compilation error: signal: segmentation fault’ in output.
Does anyone have a solution with this issue?

Hi @horden316,

May I know which OS are you currently using?

macOS Sonoma 14.3

Regarding this error, I have committed the updates earlier on to fix this issue.

You can find the updated tools in ambpro2_arduino/Arduino_package/ameba_pro2_tools_macos at dev · ambiot/ambpro2_arduino · GitHub. You can download it and replace your current tools in your SDK (Arduino15 → packages → realtek → tools → ameba_pro2_tools ->1.2.16) to give it a try.

Alternatively, we will be releasing a pre release version soon. You can wait for the prerelease.

prerelease version can be installed by inputting in Preference in Arduino IDE.

I’ve tried these two solutions, but new error message appeared.
First error message says
Compilation error: fork/exec /Users/[username]/Library/Arduino15/packages/realtek/tools/ameba_pro2_tools/1.2.16/prebuild_macos: permission denied
And then I tried to use sudo chmod -R 777 1.2.16 to give it permission, after that, another error message appeared
Compilation error: fork/exec /Users/horden/Library/Arduino15/packages/realtek/tools/ameba_pro2_tools/1.2.17/ino_validation_macos: bad CPU type in executable
I am using Intel CPU. Could this be the reason for the error message?

Hi @horden316,

This has been fixed in the latest 4.0.7 build 20240229. You should be able to compile code successfully now. Permissions issue have been fixed, users no longer need to manually give permission.

Thank you.