AMB82-MINI getting error: vipnn not applied

AMB82-MINI getting error: vipnn not applied

Running ObjectDetectionLoop.ino

it is getting video feed ok but
on Serial Monitor it is printing

Total number of objects detected = 0

error: vipnn not applied

Network URL for RTSP Streaming: rtsp://

Total number of objects detected = 0

error: vipnn not applied

Network URL for RTSP Streaming: rtsp://

1 Like

Hi @chompangyi, which SDK version are you using? You can check it at boards manager on Arduino IDE. Are you running the default examples in the SDK without modifying anything?

I have tested on Win10, Arduino IDE 2.3.2 and SDK version v4.0.6 and its working fine.

I think that it is due to no dnn file
I try to upload via conversion tool but it fails many time
is there any available YOLOV4 Tiny or YOLOV7 Tiny generated

You can find all the available default models in C:\Users{username} \AppData\Local\Arduino15\packages\realtek\hardware\AmebaPro2{SDK version}\variants\common_nn_models

For using customized model, you can refer to

rtsp stream enabledNN IRQ default priority : 0, set to 9

VIPLite Drv version 1.12.0

set yolo confidence thresh to 0.500000

set yolo NMS thresh to 0.300000

Deploy YOLOv4t

error: error: vip_create_network.

Set H264 default HIGH profile

Total number of objects detected = 0

error: vipnn not applied

Network URL for RTSP Streaming: rtsp://

which SDK version are you using?
which Arduino IDE?
which example? do you have the link of the demo or source code?

Realtek Ameba Boards(32 bit Arm v8M @500NGHz) version 4.0.6

Arduino IDE2.3.2

Running ObjectDetectionLoop example


VIPLite Drv version 1.12.0

Thank you for the reply. We had tried your env to build and this is no errors. So I would like to suggest you,

I installed Arduino and AMB82-MINI straight-forward on a new notebook. Everything worked fine - also RTSP video streaming was perfect. IDE is v2.3.2, ameba is v4.0.6.


Now I got the same error when trying to experience the given NN face detection sample: error: vipnn not applied

This error is repeated output on serial - the video can be received, but without any OSD.

Trying to increase the NN_SIZE in the linker_scripts → amebapro2_ram_arduino.ld did not work either.

Has anyone an idea for this failure?
Thank you so much for your suggestions!

1 Like

Hi @HDP,

It should be NA_MODEL instead of DEFAULT_YOLOV3TINY.

Thank you.

@chompangyi @HDP
I have the same issue as you two.
Do you see any errors during compilation? I see one that says “Invalid Parameters” or similar with any NN sketches.

I am also doing the absolute most vanilla default setup, as the only thing I change is the SSID and PW.

Other sketches work. Only NN sketches seem to have these errors which populate during compilation.

copy misc\nn_img\amebapro2_nn_model.json .\
Invalid number of parameters
        1 file(s) copied.


copy misc\nn_img\amebapro2_nn_model.json .\
        1 file(s) copied.
xcopy /y C:\Users\me\AppData\Local\Arduino15\packages\realtek\hardware\AmebaPro2\4.0.6\variants\common_nn_models .\
Invalid number of parameters

Does anyone have a solution to this? I’m getting the same “error: vipnn not applied” error for all NN examples.
Windows 11, IDE 2.3.2, SDK 4.0.7.

There is an issue with xcopy /y fucntion for nn_models requires double quotes.
xcopy /y C:\Users\User Name\AppData\Local\Arduino15\packages\realtek\hardware\AmebaPro2\4.0.6\variants\common_nn_models .
Invalid number of parameters
it should be
xcopy /y “C:\Users\User Name\AppData\Local\Arduino15\packages\realtek\hardware\AmebaPro2\4.0.6\variants\common_nn_models” .\

how can I fix this?

Hi @andyliao,

May I know if you are using 4.0.6 or 4.0.7 pre release version?

Kindly ensure that there is no space in your username for now. We will be updating the tools in the future to solve this issue.

Hi @pammyleong,
I’m using 4.0.6 (main). I also tried 4.0.6 and 4.0.7 from dev, both versions have the same compile issue.
Yes, only workaround is to compile under a username without space.