RTL8720DN connection to AP with hidden SSID

Hello,

I’m trying to connect with the RTL8720DN to an AP with hidden SSID but unfortunately I can’t get it to work. Connection to an AP with a public SSID seems to work just fine.

I’ve build the images with the standard sdk from github and included the ATCMD, command and the wifi interactive API in the build. I’ve even tried images built from release and master branches.

When I enter
wifi_connect <my_hidden_ssid>
it re-tries to connect and outputs:


RTL8721D[Driver]: set ssid [my_hidden_ssid]

After last last retry wifi_info outputs:

Last Link Error
==============================
        Target AP Not Found

When querying during retries wifi_info shows:

WIFI  wlan0 Setting:
==============================
      MODE => STATION
      SSID => 
   CHANNEL => 1
  SECURITY => AES
  PASSWORD => <the wpa pw>

Last Link Error
==============================
        Unknown Error(6)

Note that the above output prints out the wpa password but the SSID is not shown (empty).

When I try to connect with the AT command ATPN=ssid,pw
it outputs:

Can't get AP security mode and channel.

The preinstalled firmware from B&T worked just fine with hidden SSID.

What I’m missing / doing wrong?

Thanks for your help!

Marc

Edit: I just noted, that it works in 2.4Ghz Band but not in 5Ghz.

1 Like

On the current SDK available on GitHub, using the ATW0, ATW1, ATWC commands, I have tested and verified that connecting to 5GHz WiFi networks with a hidden SSID seems to be failing. The same commands works normally with hidden and regular 2.4GHz networks, and regular 5GHz networks.

Is this the same behavior you are seeing?

Hi,

Yes, exactly the same behavior.

Marc

@gigerstyle

The development team has confirmed that 5GHz WiFi only uses passive scanning, thus hidden SSIDs are not supported.
If you absolutely need to use hidden SSID, I would suggest sticking to 2.4GHz WiFi.

1 Like

Thank you for clarification.

That are bad news. I explicitly ordered these modules because of the 5GHz support and I didn’t expect to have issues regarding hidden SSID’s.

Can you ask the development team what the reason is that it isn’t supported? I can’t imagine that it is a technical limitation since it worked on the B&T firmware (which looks like it is based on the ameba-sdk).

Is there no way to get it working? Is it supported with the full-sdk?

Thanks,

Marc

1 Like

Hi @gigerstyle Marc,

If it works with B&T stock firmware, then it’s not a hardware issue, more likely needs a software patch. Please stay tuned for more updates~