[Resolved] Help needed with BW16

I got a BW16 breakout board with the USB serial adapter included.
I followed this tutorial
I setup my arduino IDE on linux.
I shorted GPIOA_8 - GPIOB_1 same for GPIOA_7 - GPIOB_2.
I tried to compile and upload the blink program after entering the upload mode, it worked fined : the arduino IDE did not output any errors.
But then I press the reset button the led is not turning on, same behavior when I unplug and plug back the board.
I tried to turn on the GPIO but again got nothing.

Something I found is that it take only 10 seconds to upload the blink program (not including the 5 seconds wait to enter upload mode) whereas in the tutorial it was more 30 seconds minimum.

Any Ideas where I may messed up something?

Hi @lefuturiste

Can you refer to this forum post How to load BW16 program with Arduino
and see if you are experiencing any of the same issues, such as seeing the B&T logo output on serial port on boot?

yes I have the B&T logo

ok, so the issue is the same as that experienced by other community members.
basically, due to incompatibilities with the B&T firmware shipped on the chip, you will need to erase the existing firmware before any Arduino uploads will work.
there are two main methods the community has found to work:

  1. Use the Arduino compiled image to generate an OTA image, and use the B&T firmware’s OTA update function to upload the Arduino OTA image onto the board

  2. Use the AmebaD Image Tool found at ambd_sdk/tools at master · ambiot/ambd_sdk · GitHub to do a full erase of the flash chip, then proceed to upload from Arduino again.

Both methods are functionally equivalent in getting rid of the default B&T firmware.

Community members have shared steps on how to do both in the previous forum link. Let me know if you have any questions

Thanks. So I finally got a blinking led here is what I did:
from: [Resources] BW16 Troubleshooting Guide.
I got my self a windows PC, download the ameba image tool.
I tried method 1 but didn’t seem to work, when I gave cmd “#ATSO=IP-address,port-number” it did open a socket and downloaded a file (from what I can see in the DownlaoadServer.exe logs) but I just got “[OK]” and not “Erase is ongoing”. It was not erasing the firmware as I could still get the A&T logo.
So I tried method 2 and it is so much simpler and it worked perfectly the firmware was gone. Then I was able to upload a script with the arduino IDE.

Thanks for the help

1 Like

great, good to hear that it is working for you.

Glad you got the blink sketch to work for you.
Am curious . Did you get the rtlduino module or the B&W16 stand alone module.
Reason i ask is,on my rtlduino,uploading the blink sketch i never got any blinking GREEN (default) LED to blink, If i edited the three lines in the blink sketch to BUILTIN_R or BUILTIN_B the led would in fact blink either blue or red whatever you specified. What am trying to say my led would never blink as the default green. Not sure why this is, I have 4 rtlduino to test on.

@brcisna I got the module with the green PCB idk if it’s called a “rtlduino” but you get the idea