Datasheets - 'insufficient permissions' to read them

I will be designing a custom board to use with the BW16, and would like to download the proper documentation both for the module, and for the 8720 chip itself.
If I use the Documentation link at the top of this forum, I get to a website with links to click, but am then told “your account has insufficient permissions to access this content”
What do I have to do to join the priveleged few able to see this information? :wink:

Hi @boatbodger,

To download the documentation, you will have to register an account on the Ameba Official Website.
Here’s the link to register an account:

When I click on that link, it says “already logged on”, as I had previously registered there.
Do I need to create a different account from the one I use on this forum?

Yes. The Official Website account is different from this forum account. So you need to create another account on the Official Website. But if you have already registered on the Official website, you should be able to download the documents, I have tried it just now, I was able to download them.

Created a new account with a different email address - same result:

OK, I cleared out all cookies for everything to do with amebaiot, and was then able to download the datasheet - thank you for your support.